• Bug in text display


    M.cochini
    • Version: Not Listed Pending Bug

    Hello !

     

    It's been a while that I'm getting a bug in every text displayed in Spartan UI, I've been trying to get it fixed by myself but can't get it done so I'm asking for help. It's kind of annoying because it's really hard to read quickly the text.

    So the bug is that instead of having some sort of "space" separating the thousands, millions, etc... It displays an inversed "??". For example, 547 will show 547. But 1547, instead of showing "1 547" will show "1??547". You can imagine how it looks when it comes to artifact power bar, with numbers in billions ("100??000??000??000" for example). I've attached a screenshot to show this on the XP bar on a reroll for example. 

    When choosing to display the text as "Long", no problem at all (can't choose this style for status bars though, only for health and mana) but it's heavy numbers for health on a lvl110 tank. As "Dynamic", it works well only for numbers above 1M (for example, 10574 will display "10??574" instead of "10,57K" or "10K 574", I don't remember but I know it's ok, BUT 1500000 will appear as "1.5M" just as it should). "Long formatted" will have both problems (long numbers AND the "??" bug). 

    Could you help me to fix this?

    Thank you very much

     

    SUI version : 4.4.5 (Last)

    Game version : 7.3.2 (Last)

     


      Report Bug


    User Feedback


    This has to do with the default font spartanUI uses does not support other languages well. go into the spartan ui settings /sui and change the font to something else.

    Share this comment


    Link to comment

    Thank you for the quick answer !

    I went to settings (/sui) then General, Font Style & Size, and put Font Style as Normal, and Font Type as Arial Narrow (this font works in other addons like Recount) and did a /reload. The font has indeed been changed, but the "??" bug is still there...

    Capture2.PNG

    Capture3.PNG

    Share this comment


    Link to comment

    If language is a problem, can autodetection simply be turned off ? I don't care if Spartan is displayed in english. 

    Share this comment


    Link to comment


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now


  • PENDING = This report is new and being looked into.

    FIXED = The issue has been fixed and will be available in the update.

    CLOSED = Topic better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

  • Categories

  •  

    View all bugs