• Sign in to follow this  

    Camera follow broken


    Eloosive
    • Version: 4.2 Closed Bug Priority: Normal

    When logging in on first toon everything is fine until you either 1) go AFK and Spin Cam activates, or 2) you log out and into a second toon. In either case, camera follow becomes disabled and will not return to normal ability until you exit the game entirely and log back in. Then it's the same situation - switch toons or go AFK and camera follow is broken again. I have disabled Spin Cam and that prevented the first toon login from breaking after AFK, but when logging into second toon, with Spin Cam disabled, it still broke camera follow.


      Report Bug
    Sign in to follow this  


    User Feedback


    This is actually a blizzard bug. If you open wow, disable all addons login it will work, then reload your UI (/reload) and it will stop working. 

    Share this comment


    Link to comment

    SpartanUI cannot affect your play experience while it is disabled. More than likely blizzard broke something with their save camera State function, just like they broke the action cam and just like they broke the viewport. Spartan's spin cam uses the built in save camera function to store your camera settings, activate the spin, and then restore your settings once you return from AFK. Blizzard uses it between reloads and between character swaps, things that are done less in an average play session. Because the spin cam tends to activate in the middle of your play session Spartan is just more noticeable. 

     

    There's a blue post a few days ago talking about them fixing a bunch of camera stuff and the viewport on the internal build hopefully we will see this really soon and hopefully it will include a fix for this.

    Share this comment


    Link to comment

    I get what you're saying, but here's the problem: people reporting this issue, here and on other sites, all have the very same common denominator - SUI. A friend of mine recently came back to WoW and I told him how awesome SUI is and he decided to use it himself. I personally was at his house before the install. I did several tests on the camera issue using all the ways to get it to stop properly following. None of them affected the camera at all, everything was fine. After the SUI install he got the camera follow bug right away. So while you say SUI is not actively changing functions of the camera coding or whatever, there IS something that happens when you install SUI on a machine that has never had SUI on it before. There's no way to claim it's not anything to do with SUI. Something in the installation/setup of SUI affects the camera follow.

    Share this comment


    Link to comment

    Hi...

     

    I'm having this same problem. The camera follow feature was completely ok before installing SUI. I've installed SUI 2 days ago and since then my camera follow stopped working. 

    I use the "Only horizontal when moving" style and now, even this is working. Now I have to set the camera manually before starting walking to be able to see properly. 

    Thanks.

    Share this comment


    Link to comment

    Hi don't know if you guys need help but I came here for the same reason, anyways if you go into your add-ons by hitting the ESC key, scroll down to Spartan UI. Under it you will have sub add-ons, framework, style, etc. Click the sub add-on that says spincam, reload UI and you should be all set. Hope this helps.

    Share this comment


    Link to comment

    I just recently switched my UI to SpartanUI, and have encountered the same issue. I tried disabling the SpartanUI-Spin Cam sub add-on, and I still have the problem. I really like the look and feel of this UI, and other than the camera making me have the drunk effect all the time (which is MOST unhelpful in PvP), I've had no issues. 

    Please advise if there's a fix that actually fixes the problem.

    Share this comment


    Link to comment


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now


  • PENDING = This report is new and being looked into.

    FIXED = The issue has been fixed and will be available in the update.

    CLOSED = Topic better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

  • Categories

  •  

    View all bugs