Sign in to follow this  
Followers 0
Calca

[Bug]Auto sell not working

10 posts in this topic

I downloaded the newest version and now auto-sell doesn't work at all. I do have the module enabled and the grey and purple enabled but now it isn't doing anything.


View full bug

0

Share this post


Link to post

As an update, auto-sell works on my alts with the exact same profile but not my main. I even copied my alts profile settings to my main and it still won't autosell.

 

This is the LUA bug

 

Message: Interface\AddOns\SpartanUI\components\AutoSell.lua:227: bad argument #1 to 'find' (string expected, got nil)
Time: 11/13/16 00:34:59
Count: 7
Stack: [C]: in function `find'
Interface\AddOns\SpartanUI\components\AutoSell.lua:227: in function `IsSellable'
Interface\AddOns\SpartanUI\components\AutoSell.lua:143: in function `SellTrashInBag'
Interface\AddOns\SpartanUI\components\AutoSell.lua:285: in function `SellTrash'
Interface\AddOns\SpartanUI\components\AutoSell.lua:313: in function <Interface\AddOns\SpartanUI\components\AutoSell.lua:310>

Locals: (*temporary) = nil
(*temporary) = "Treasure Map"
(*temporary) = "string expected, got nil"

 

0

Share this post


Link to post

Here is the screenshot. I have green enabled and the debug. It looks like it's trying to sell a low level green I have, but is unable to. Low purples and trash are not even registering in the debug. This is no problem on my alts so I have no idea why it's just happening with 1 character.

 

I have also tried using a fresh cache and wtf file along with having SUI the only add-on loaded and the exact same thing happens so I'm not sure if there's something in my inventory freaking the mod out or what. WoWScrnShot_111316_004443.jpg

0

Share this post


Link to post

I am having this problem as well as one with enemy target portraits not showing up if I am brought into combat. If I initiate combat, it's fine except the target of target bar won't show. I've checked all my settings, but this is an account wide issue, even when different characters have different settings.

0

Share this post


Link to post

Found that removing Dreadmaw (caged pet) resolved the issue for me. 

I am guessing that the new pets may be the root of the issue.

1

Share this post


Link to post
22 hours ago, Fellon said:

Found that removing Dreadmaw (caged pet) resolved the issue for me. 

I am guessing that the new pets may be the root of the issue.

I had a caged pet in my inventory, it wasn't a new pet at all but it was something I had been carrying around forever. Putting it in my bank fixed this issue. I guess caged pets screw up the mod somehow with auto sell.

Thanks for figuring it out.

0

Share this post


Link to post

I have this issue but do not have any pet cages in my inventory. Every time I open a vendor for the first time I get this error

Date: 2017-05-29 14:15:56
ID: 1
Error occured in: Global
Count: 1
Message: ..\AddOns\SpartanUI\components\AutoSell.lua line 227:
   bad argument #1 to 'find' (string expected, got nil)
Debug:
   [C]: ?
   [C]: find()
   SpartanUI\components\AutoSell.lua:227: IsSellable()
   SpartanUI\components\AutoSell.lua:143: SellTrashInBag()
   SpartanUI\components\AutoSell.lua:285: SellTrash()
   SpartanUI\components\AutoSell.lua:313:
      SpartanUI\components\AutoSell.lua:310
Locals:

AddOns:
  Swatter, v7.0.5 (<%codename%>)
  NPCScanOverlay, v7.1.0.1
  ACP, v3.4.30
  Archy, v7.2.0.1
  Arh, v1.6.4
  AskMrRobot, v50
  AtlasLoot, vv8.03.07
  AtlasLootBurningCrusade, vv8.03.07
  AtlasLootCataclysm, vv8.03.07
  AtlasLootClassic, vv8.03.07
  AtlasLootLegion, vv8.03.07
  AtlasLootMistsofPandaria, vv8.03.07
  AtlasLootWarlordsofDraenor, vv8.03.07
  AtlasLootWrathoftheLichKing, vv8.03.07
  Auctionator, v4.0.17
  AutoCombatLogger, v7.2.0
  Babylonian, v5.1.DEV.332(/embedded)
  BagBrother, v
  Bagnon, v7.2.5
  Bartender4, v4.7.7
  ClassMods, vv1.32
  Configator, v5.1.DEV.406(/embedded)
  CrossRealmAssist, v0.81 beta
  DBMCore, v7.2.7
  DBMDefaultSkin, v
  DBMStatusBarTimers, v
  FlashTaskBar, v
  Gatherer, v7.0.5
  HandyNotes, vv1.4.13
  HandyNotesDraenorTreasures, v1.20a
  HandyNotesLegionRaresTreasures, v1.01b
  HandyNotesLegionTreasures, v1
  IskarAssist, v
  LibSharedMedia30, v3.0-97
  LootAppraiser, v2016.v1.6.15
  Mapster, v1.7.5
  MasterPlanA, vA
  MogIt, v3.8.1
  MogItHighlighter, vv1.3.2
  MogItLeather, v3.8.1
  MogItOneHanded, v3.8.1
  MogItOther, v3.8.1
  MogItRanged, v3.8.1
  MogItSetTransmog, v1.5.1
  MogItTwoHanded, v3.8.1
  MoveAnything, v16.1.9
  NPCScan, v7.2.0.2
  Omen, v3.1.12
  OmniCC, v7.2.0
  Pawn, v2.2.5
  Postal, vv3.5.8
  Quartz, v3.3.4
  REFlex, v2.2.5
  SexyMap, vv7.2.0
  SimpleILevel, v3.3.10
  SimpleILevelGroup, v3.3.10
  SimpleILevelResilience, v3.3.10
  SimpleILevelSocial, v3.3.10
  Simulationcraft, v1.7.1
  Skada, v1.6.7
  SlideBar, v7.0.5 (<%codename%>)
  SpartanUI, v4.4.0
  SpartanUIAnimated, v1.4.0
  SpartanUIArtwork, v3.3.0
  SpartanUIFilmEffects, v3.1.4
  SpartanUIPartyFrames, v3.3.0
  SpartanUIPlayerFrames, v3.3.0
  SpartanUIRaidFrames, v3.3.0
  SpartanUISpinCam, v3.1.4
  SpartanUIStyleFel, v1.0.0
  SpartanUIStyleMinimal, v3.3.0
  SpartanUIStyleTransparent, v3.3.0
  SpellBinding, v1.0.0
  SpellFlashCore, v2.1.5
  TidyPlates, v6.18.11
  TidyPlatesThreatPlates, v8.3.4
  TidyPlatesHub, v
  TidyPlatesWidgets, v
  TipTac, v16.10.27
  TipTacItemRef, v16.10.27
  TipTacTalents, v16.10.27
  Titan, v5.11.5.70200
  TitanBag, v5.11.5.70200
  TitanClock, v5.11.5.70200
  TitanGold, v5.11.5.70200
  TitanLocation, v5.11.5.70200
  TitanLootType, v5.11.5.70200
  TitanPerformance, v5.11.5.70200
  TitanRepair, v5.11.5.70200
  TitanVolume, v5.11.5.70200
  TitanXP, v5.11.5.70200
  TomTom, vv70200-1.0.0
  TradeSkillMaster, vv3.6.28
  TradeSkillMasterAccounting, vv3.0.19
  TradeSkillMasterAppHelper, vv3.0.3
  TradeSkillMasterAuctionDB, vv3.1.17
  TradeSkillMasterAuctioning, vv3.0.15
  TradeSkillMasterCrafting, vv3.2.4
  TradeSkillMasterMailing, vv3.0.14
  TradeSkillMasterPriceReply, vv3.2
  TradeSkillMasterShopping, vv3.4.6
  TradeSkillMasterTDAutoVendoring, v1.4.1
  TradeSkillMasterVendoring, vv3.0.6
  TradeSkillMasterWarehousing, vv3.0.5
  WIM, vr524
  BlizRuntimeLib_enUS v7.2.0.70200 <none>
  (ck=b2e)

 

0

Share this post


Link to post

Mythic keystones also cause the problem if they are in your inventory. I throw mine in the bank until I use it.

0

Share this post


Link to post

Changed Status to Fixed

0

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0