Sign in to follow this  
Crystalinn

[Bug]Autosell LUA error (vers. 4.4.3)

2 posts in this topic

Message: Interface\AddOns\SpartanUI\components\AutoSell.lua:227: bad argument #1 to 'find' (string expected, got nil)
Time: 06/24/17 11:50:48
Count: 3
Stack: Interface\AddOns\SpartanUI\components\AutoSell.lua:227: bad argument #1 to 'find' (string expected, got nil)Interface\SharedXML\SharedBasicControls.lua:204: in function <Interface\SharedXML\SharedBasicControls.lua:203>
[C]: ?
[C]: in function `find'
Interface\AddOns\SpartanUI\components\AutoSell.lua:227: in function `IsSellable'
Interface\AddOns\SpartanUI\components\AutoSell.lua:143: in function `SellTrashInBag'
Interface\AddOns\SpartanUI\components\AutoSell.lua:285: in function `SellTrash'
Interface\AddOns\SpartanUI\components\AutoSell.lua:313: in function <Interface\AddOns\SpartanUI\components\AutoSell.lua:310>

Locals: errorMessage = "Interface\AddOns\SpartanUI\components\AutoSell.lua:227: bad argument #1 to 'find' (string expected, got nil)"
DisplayMessageInternal = <function> defined @Interface\SharedXML\SharedBasicControls.lua:187
MESSAGE_TYPE_ERROR = 0

 

Chatting with a vendor spawns this error. The gold calculation/number of items to sell doesn't show in chat.

Every once in a while it'll resolve itself, and autosell will work again, but I'm not sure what triggers it. It's character specific (as in, I get the LUA error on my shaman, but not my hunter, or rogue, or anyone else for that matter), and disabling and re-enabling the autosell module does not fix it. 

EDIT (27/06/17): It was working when I logged on, I hearthed to Dal, picked up Nomi's mistakes, completed/started some missions, recruited troops, and checked my artefact for stray points. I then went to chat with a vendor and got a LUA error to the face. So, either something there triggered it, or it's just entirely random. 

 

View full bug

 

Edited by Crystalinn
New info

Share this post


Link to post

Getting this same error with mine, and the same things happening.  Sometimes it will resolve itself and sell fine, other times I get the error every time I speak to vendors.  I also have the addon SellJunk loaded, does /sui have an autosell component that is conflicting with SellJunk perhaps, and if so would unloading SellJunk help with the errors?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this