• Announcements

    • libidos

      Legion Launch: Urgent issues   08/29/2016

      If you are here to post an urgent issue or have an issue that is impeding your play in legion please connect to the SpartanUI Chat server in your curse client. via the link below or you can search for SpartanUI. https://curse.com/invite/MWJBYnOhiUOoe2e47BTuVQ  

Leaderboard


Popular Content

Showing content with the highest reputation since 09/03/2015 in all areas

  1. 2 points
    No I just am not raiding right now so WoW has not been able to keep my attention. (Have to get all those Overwatch loot boxes) I still have an active sub. Have for 10 years straight if something breaks I will always popup. I tend to go through waves of large development and updates usually fall to late winter then try to spend more time outside with family over the summer. Edit - x-post from chat: I have been maintaing and growing this addon for a very long time all by myself. There is no team just me. @jainaproudmoore has been very helpful recently since i stood up this chat helping people and i could not be more grateful. Thanks @jainaproudmoore so many times i open the chat thinking ugh whats blown up in the week i have had it closed and see everything taken care of - for the most part at least :)
  2. 2 points
    I use the minimap on the bottom and would like to have my buffs on the top rigth corner but they are a bit to the left. /sui -> Artwork -> Buff settings -> Changing all those do not change anything, even after a reload.
  3. 1 point
    Getting this aswell.
  4. 1 point
    Message: Interface\AddOns\SpartanUI\components\AutoSell.lua:227: bad argument #1 to 'find' (string expected, got nil) Time: 06/24/17 11:50:48 Count: 3 Stack: Interface\AddOns\SpartanUI\components\AutoSell.lua:227: bad argument #1 to 'find' (string expected, got nil)Interface\SharedXML\SharedBasicControls.lua:204: in function <Interface\SharedXML\SharedBasicControls.lua:203> [C]: ? [C]: in function `find' Interface\AddOns\SpartanUI\components\AutoSell.lua:227: in function `IsSellable' Interface\AddOns\SpartanUI\components\AutoSell.lua:143: in function `SellTrashInBag' Interface\AddOns\SpartanUI\components\AutoSell.lua:285: in function `SellTrash' Interface\AddOns\SpartanUI\components\AutoSell.lua:313: in function <Interface\AddOns\SpartanUI\components\AutoSell.lua:310> Locals: errorMessage = "Interface\AddOns\SpartanUI\components\AutoSell.lua:227: bad argument #1 to 'find' (string expected, got nil)" DisplayMessageInternal = <function> defined @Interface\SharedXML\SharedBasicControls.lua:187 MESSAGE_TYPE_ERROR = 0 Chatting with a vendor spawns this error. The gold calculation/number of items to sell doesn't show in chat. Every once in a while it'll resolve itself, and autosell will work again, but I'm not sure what triggers it. It's character specific (as in, I get the LUA error on my shaman, but not my hunter, or rogue, or anyone else for that matter), and disabling and re-enabling the autosell module does not fix it. EDIT (27/06/17): It was working when I logged on, I hearthed to Dal, picked up Nomi's mistakes, completed/started some missions, recruited troops, and checked my artefact for stray points. I then went to chat with a vendor and got a LUA error to the face. So, either something there triggered it, or it's just entirely random. View full bug
  5. 1 point
    Changed Status to Fixed
  6. 1 point
    Glad i'm not the only one. I just check it on my laptop client and its experiencing the same problem.
  7. 1 point
    Having the same problem with mine, hopefully an update will follow soon.
  8. 1 point
  9. 1 point
  10. 1 point
    Can confirm this is a bug as I am also having this issue. Had to disable the PlayerFrame submod and go with default Blizzard frames for now.
  11. 1 point
    Found that removing Dreadmaw (caged pet) resolved the issue for me. I am guessing that the new pets may be the root of the issue.
  12. 1 point
    I think I have some insight into this bug as I also experienced this issue today. There is a specific combination of settings which triggers this issue, I found. In Player Frames > Buffs & Debuffs > Player: set Buffs: Disabled set Debuff: Icons I wanted this because I'm using WeakAuras to show relevant buff info and I want to just see icons of the debuffs which are on me but apparently this causes the Player and Target frames to disappear. Temp. Solution - import your settings from a different character or reset your profile and the frame should return. TS
  13. 1 point
    When downloading the latest update 4.3.2 release, my player frames are no longer there and there is a red bar across the bottom of the mini map. restoring to 4.3.1-Release-4-gc406216 and the issues go away. Hope this can be fixed as this is by far the best looking UI out there currently. View full bug
  14. 1 point
    I've been using this UI for years now and love the improvements that have been made, but with the launch of Legion very near I would like to see a Artifact Power bar added to the UI, as it is a, I feel a new and very integral part of the UI.
  15. 1 point
    Just updated and it hasn't fixed the player frames being missing
  16. 1 point
    I have no idea how to fix it. I even downloaded the beta that was released and it didn't fix it. I downloaded the newest files and it didn't help and bartender throws off a bunch of errors. View full bug
  17. 1 point
    Hello guys, I have one problem. I can`t move the buffs from the player and target. And the buffs are not directly on the player. Look at the Screenshot Thank you very much
  18. 1 point
    Fixed in latest alpha builds. got a bit more tweaking to do to buffs before another release build.
  19. 1 point
    even when I was pressing the skipping button it would ask to reset ui.
  20. 1 point
    Just pushed 4.2.2-Release-4 to fix this.
  21. 1 point
    Do you have any plan with buffs above player/target frame? For examples: Buff icon size scale. Display buff only or debuff only or both. Display buff/debuff cast by me only. Max number of buff to display. Toggle cool down number on buff. This is important cause when buff icon is small with a big number on it. Very hard to see the icon image and what is that buff. Especially when there are so many icons. Thank you. View full bug
  22. 1 point
    Do you have any plan with buffs above player/target frame? For examples: Buff icon size scale. Display buff only or debuff only or both. Display buff/debuff cast by me only. Max number of buff to display. Toggle cool down number on buff. This is important cause when buff icon is small with a big number on it. Very hard to see the icon image and what is that buff. Especially when there are so many icons. Thank you.Â
  23. 1 point
    Do the transparent ones work? Those are very similar in the backend to Classic a lot of the same code was used for both styles. Also try and grab the latest alpha build. http://wow.curseforge.com/addons/spartan-ui/files/
  24. 1 point
    So, you want me to remove the spartanui.lua and .lua.bak files from the saved variables folder in the WTF folder? cause i did that and all it did was get rid of all my profiles and didn't fix the issue :/ i'll try to fresh install the addon again. Update: I just tried to fresh install spartanui and remove some of my old or unused addons, like Auctioneer suite that hasn't been updated yet, and still classic party frame is the only thing not working for me. :/ minimal works and is ok, but i don't like it quite as much as classic.
  25. 1 point
    After activating Swatter, i noticed in the reload he gives this error msg : Date: 2016-02-22 11:50:15 ID: -1 Error occured in: Global Count: 5 Message: ...nterface\AddOns\SpartanUI\libs\oUF\elements\aura.lua line 209: attempt to index field 'overlay' (a nil value) Debug: ...nterface\AddOns\SpartanUI\libs\oUF\elements\aura.lua:209: ...nterface\AddOns\SpartanUI\libs\oUF\elements\aura.lua:141 ...nterface\AddOns\SpartanUI\libs\oUF\elements\aura.lua:293: ...nterface\AddOns\SpartanUI\libs\oUF\elements\aura.lua:287 ...nterface\AddOns\SpartanUI\libs\oUF\elements\aura.lua:360: ...nterface\AddOns\SpartanUI\libs\oUF\elements\aura.lua:314 (tail call): ? Locals: unit = "target" icons = <unnamed> { 0 = <userdata> 2 = <unnamed> { } growth-y = "UP" numDebuffs = 10 spacing = 1 size = 20 __owner = SUI_targetFrame { } onlyShowPlayer = false anchoredIcons = 2 PostUpdate = <function> defined @Interface\AddOns\SpartanUI_PlayerFrames\scripts\FrameStyle_Classic.lua:103 showType = true gap = true 1 = <unnamed> { } visibleAuras = 1 visibleBuffs = 1 numBuffs = 5 initialAnchor = "BOTTOMRIGHT" visibleDebuffs = 0 growth-x = "LEFT" createdIcons = 2 ForceUpdate = <function> defined @Interface\AddOns\SpartanUI\libs\oUF\elements\aura.lua:452 } index = 1 offset = 0 filter = "HARMFUL" isDebuff = true visible = 0 name = "Growl" rank = "Basic Ability" texture = "Interface\Icons\Ability_Physical_Taunt" count = 0 dtype = nil duration = 3 timeLeft = 16324.437 caster = "pet" isStealable = false shouldConsolidate = false spellID = 2649 canApplyAura = true isBossDebuff = false n = 1 icon = <unnamed> { UpdateTooltip = <function> defined @Interface\AddOns\SpartanUI\libs\oUF\elements\aura.lua:68 isDebuff = true stealable = <unnamed> { } owner = "pet" cd = <unnamed> { } filter = "HARMFUL" 0 = <userdata> icon = <unnamed> { } count = <unnamed> { } } isPlayer = nil show = true cd = <unnamed> { omniccActivate = SUI_targetFrameOmniCCActivate { } omnicc = <unnamed> { } 0 = <userdata> omniWidth = 20.000057171732 } color = <table> { b = 0 g = 0 r = 0.8 } (*temporary) = nil (*temporary) = nil (*temporary) = nil (*temporary) = 16321.437 (*temporary) = 3 (*temporary) = <unnamed> { omniccActivate = SUI_targetFrameOmniCCActivate { } omnicc = <unnamed> { } 0 = <userdata> omniWidth = 20.000057171732 } (*temporary) = <function> defined @Interface\AddOns\OmniCC\core\timer.lua:38 (*temporary) = <unnamed> { 0 = <userdata> abRatio = 0.55555555555556 text = <unnamed> { } enabled = true textStyle = "charging" visible = true duration = 3 finish = 16324.437 start = 16321.437 charging = true cooldown = <unnamed> { } controlled = false } (*temporary) = 16321.437 (*temporary) = 3 (*temporary) = <function> defined @Interface\AddOns\OmniCC\core\timer.lua:153 (*temporary) = <unnamed> { 0 = <userdata> abRatio = 0.55555555555556 text = <unnamed> { } enabled = true textStyle = "charging" visible = true duration = 3 finish = 16324.437 start = 16321.437 charging = true cooldown = <unnamed> { } controlled = false } (*temporary) = <function> defined @Interface\AddOns\OmniCC\core\timer.lua:89 (*temporary) = <unnamed> { 0 = <userdata> abRatio = 0.55555555555556 text = <unnamed> { } enabled = true textStyle = "charging" visible = true duration = 3 finish = 16324.437 start = 16321.437 charging = true cooldown = <unnamed> { } controlled = false } (*temporary) = "attempt to index field 'overlay' (a nil value)" createAuraIcon = <function> defined @Interface\AddOns\SpartanUI\libs\oUF\elements\aura.lua:83 customFilter = <function> defined @Interface\AddOns\SpartanUI\libs\oUF\elements\aura.lua:135 VISIBLE = 1 HIDDEN = 0 AddOns: Swatter, v5.21f.5579 (SanctimoniousSwamprat) SpartanUI, v4.1.0 SpartanUIArtwork, v3.3.0 SpartanUIFilmEffects, v3.1.4 SpartanUIPartyFrames, v3.3.0 SpartanUIPlayerFrames, v3.3.0 SpartanUIRaidFrames, v3.3.0 SpartanUIStyleMinimal, v3.3.0 SpartanUIStyleTransparent, v3.3.0 Stubby, v5.21f.5579 (SanctimoniousSwamprat)
  26. 1 point
  27. 1 point
  28. 1 point
    I'm having the same problem. when i first login/reload ui the icons are about 1.5 inch from the right. then they snap to the far right an they become "dead" and don't show tool tips. its almost like the UI still thinks vanilla map is till in the corner so don't allow clickthrough/hover.
  29. 1 point
    Below you will find the currently planned features for the next few SpartanUI Releases 4.1 - Initial Legion Update; Minor Tweaks & Bug Fixes.4.2 - Action bar movement revamp. This will now be handled by SUI and not bartender.4.3 - Unit frame & buff improvments. 4.4 - Chat Component4.5 - Theme Improvements - Example: Minimal Style has some "Hide-able" drawers. Guess what they don't do right now. All of the above is tentative, some might happen at the same time. Due to user requests this list might re-order or change. This post will be updated with future plans as they change.
  30. 1 point
    Make sure you've downloaded the newest one (should be on curse now) and i fresh installed mine, but not sure if you have to. Curse was giving the old version last night. you may also try changing the artwork style, because for some reason classic party frames weren't appearing for me. could be the same with yours maybe.
  31. 1 point
    Still shows as "Out of Date" in addon list and does not load. If I turn it on to load nothing shows up in the right place.
  32. 1 point
    Tried using r20160720015912 but all that comes up is the profile pic of my toon; no framework, no artwork and the map is still in the upper right corner. I have to manually move my action bars. I assume that this will be fixed with the Artwork component upload. On the plus side, it does say that most of the components are now up to date. :P
  33. 1 point
    Yes i started on the code for it then started leveling my hunter and got sick of my bags filling up and thus the Auto Sell and Auto Turn in modules were born. I want to get back to the Buffs modules latter this week.Â
  34. 1 point
  35. 1 point
    Same here, I get a lua error when it first starts and when I try to re-enable it. This is what I get Message: ...ce\AddOns\SpartanUI_Artwork\Themes\Classic\Style.lua:198: attempt to call method 'UpdateBuffPosition' (a nil value) Time: 09/30/15 11:13:00 Count: 1 Stack: ...ce\AddOns\SpartanUI_Artwork\Themes\Classic\Style.lua:198: in function <...ce\AddOns\SpartanUI_Artwork\Themes\Classic\Style.lua:196> (tail call): ? [C]: ? [string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5> (tail call): ? ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:799: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:614> (tail call): ? [C]: ? [string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5> (tail call): ? ...ace\AddOns\Bartender4\libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire' ...r4\libs\AceGUI-3.0\widgets\AceGUIWidget-CheckBox.lua:68: in function <...r4\libs\AceGUI-3.0\widgets\AceGUIWidget-CheckBox.lua:57>Â Locals: <none>
  36. 1 point
    I'm having the same issue. My buffs used to be all the way to right on the top of the screen since my map is in the center on the bottom of the screen. Now it's offset to the left like my map is still in the top right of the screen. I attached a picture below showing where the buffs are currently.
  37. 1 point
    Since you disabled the minimap module that would not be a bug since you turned off some of the functionality. Can you turn on LUA errors in your blizzard options? i would recommend grabbing bugsack to make lua error copyable. let me know if you get any errors. I will work on looking through your list of addons latter tonight.
  38. 1 point
    I am re-working the way SpartanUI will handle buffs and give you more options on display method. Â Honestly i completely forgot about this specifically I will start poking at this once the LUA error related bugs start to die down.
  39. 1 point
    I am having the same issue, no matter what settings I change or switch around the buffs at the top do not move. Â They stay the default blizzard UI space away from the right hand side. Â With previous SUI they always offset to the right, in order to not look weird. Â Since new update this no longer happens. Â
  40. 1 point
    Yes and Yes. That 2nd drop down will come back however right now it was "broken" all buttons are being treated as a whole at the moment. The changes needed to support both was more than i could do on a raid night. I try to stick to the raw bugs on raid night, RL does not like it when I do more.
  41. 1 point
    Oh my gosh you two. Keep the ideas rolling.
  42. 1 point
    Fixed this in alpha r224, just uploaded r226 to release.
  43. 1 point
    SUI_Tooltips_errors_GameTooltip_SetDefaultAnchor.txt - I think this is being triggered by no rules being matched, added a failback of Rule1 and it will print a message if failback happens. need to keep an eye out and see if it comes back. SUI_Tooltips_errors_ObjTrackerUpdate.txt - Copy paste Fail on the new options.
  44. 1 point
    Nice if you add an option to skin the tooltip and skin the border, like tiptac does
  45. 1 point
    SpartanUI's move command has been renamed to /suimove
  46. 1 point
    Yes that is a issue in r217, r219 should fix that for you
  47. 1 point
    Ended up rebuilding most of the film effects. not to fix the bug but because i did not like what i found when i opened the file
  48. 1 point
    Please add features to buff & debuff above the palyer and target frame (sorted by the order of importance) : Show my buff & debuff only.Adjust buff & debuff icon size.Toggle cool down number on icon.Toggle cool down animation on icon. It really hard to recognize when icons are too many, too small and having number or animation on them cover the image of icon. Thank you and have a nice day.
  49. 1 point
    What about to adding an option that allow to choose the fonts from shared media?
  50. 1 point
    I check the box to show me the lua errors, but there are no lua error by hit ALT+Z Maybe my resolution causes problems? I play on 1920x1080 Â UPDATE: I just disabled the Viewport. It fixed my problem.